Author Topic: Clutch fluid problems  (Read 274 times)

0 Members and 1 Guest are viewing this topic.

Offline Phmode

  • Administrator
  • Hero Member
  • *****
  • Posts: 7808
  • Karma: +64/-15
  • I am the evil webmaster, do not cross me!
    • View Profile
  • My K bike model:: BMW K1300S 2012
  • Modifications and add-ons:: Sargent Seat, Powerbronze Screen, Akrapovic Silencer, Ilmberger Hugger, K12S Black Top Yoke, Helibars, Cruise, Centre Stand, Sidestand Extender, Full 3M Film, Barkbusters Hand Guards in winter.
  • Location:: Ledbury, Herefordshire
Re: Clutch fluid problems
« Reply #15 on: April 26, 2018, 10:16:03 pm »
Probably. EPDM vs Nitrile seals  :o

Offline MadMountainbike

  • Newbie
  • *
  • Posts: 49
  • Karma: +1/-0
    • View Profile
  • My K bike model:: K1200s
  • Modifications and add-ons:: Oberon Clutch Mod
  • Location:: Yorkshire
Re: Clutch fluid problems
« Reply #16 on: April 29, 2018, 09:49:28 pm »
Could be a big problem if left. The clutch uses mineral oil not DOT fluid. It needs cleaning out straight away otherwise it'll damage all the seals and hoses from the lever to the slave.

.

Really?


Yes, hydraulic systems running mineral oil use different materials for hose linings and seals, using DOT will damage them and cause premature failure if left.

I used to race and still look after a few Race XC Mountainbikes, Shimano use mineral oil in their top end brakes, had a few where people used the wrong fluid. Obviously you'd need to leave the stuff in there a while, but ultimately it will damage the system.
Sometime XC racer, zero bike skills. Keen skier, no technique. Ex President & hopeless optimist... Especially at high speed or high altitude.